BeBot - An Anarchy Online and Age Of Conan chat automaton

General => News => Topic started by: Khalem on October 29, 2009, 08:24:14 pm

Title: BeBot v0.6.6 released - The not so scary halloween edition
Post by: Khalem on October 29, 2009, 08:24:14 pm
This is primarily a hotfix release to address login issues following Age of Conan patch.
Please see Changelog for other changes.

Download:
https://launchpad.net/bebot/+download

-------------
Version 0.6.6
-------------
- Add detection of missing config file and try to detect if config file was not read properly.
- Added setting for what raid types to show in raid control start raid links
- Added a best match function to tools module
- Added waypoint support to rally
- Added a General queue module Changed chatqueue buddy_queue and masmsg (invites) to use
- Fixed login in AoC after patch 1.05.6
Title: Re: BeBot v0.6.6 released - The not so scary halloween edition
Post by: WeZoN on October 30, 2009, 03:03:43 pm
i updated and it does not work...

I get that the computer activly refuses the connection...

I've even tried the older version with the new aochat but still nothing..

 
Title: Re: BeBot v0.6.6 released - The not so scary halloween edition
Post by: Khalem on October 30, 2009, 05:59:29 pm
That sounds odd.

Was it working fine pre patch?
Which server are you on?

Tbh this sounds more like a firewall issue than anything else.
Title: Re: BeBot v0.6.6 released - The not so scary halloween edition
Post by: WeZoN on October 30, 2009, 06:04:56 pm
i'm running it on a dedicated external server with all ports like i want them.

Server: Aquilonia

Working like a dream pre-patch yes..  Full 3 months without crash
Title: Re: BeBot v0.6.6 released - The not so scary halloween edition
Post by: WeZoN on October 30, 2009, 06:08:03 pm
Code: [Select]
Bettiebot [LOGIN]       [STATUS]        Connecting to aoc server aoc-eu-um.live.
ageofconan.com:7000

Warning: Could not connect to the AOC Chat server (aoc-eu-um.live.ageofconan.com
:7000): No connection could be made because the target machine actively refused
it.
 in C:\Guildbot\Sources\AOChat.php on line 247
Bettiebot [CONN]        [ERROR] Can't connect to server. Retrying in 60 seconds.
Title: Re: BeBot v0.6.6 released - The not so scary halloween edition
Post by: Khalem on October 30, 2009, 06:24:00 pm
I am unable to reproduce this and i can connect just fine.

Keep in mind that aoc-eu-um.live.ageofconan.com is a DNS round robin which in addition serves different views depending on where you are located, so it could be a case of a UM server being down, or your servers nameserver DNS caches being outdated.

I know Funcom have fairly strict firewall rules going as well which could be triggered by excessive connection attempts. But I am not certain if that happening would result in reject packages being sent (the sane thing from a DoS perspective would be not to)

In any case i can assure you this is beyond our control and is not influenced in any way by BeBot. It is attempting to connect to the IP it is given by your server when it asks for aoc-eu-um.live.ageofconan.com to be looked up on the correct port which is 7000.
Title: Re: BeBot v0.6.6 released - The not so scary halloween edition
Post by: WeZoN on October 30, 2009, 06:38:11 pm
will test out the bot on my local machine to check..
Title: Re: BeBot v0.6.6 released - The not so scary halloween edition
Post by: WeZoN on October 30, 2009, 07:18:00 pm
Ok. As i need to set up the database server and so on i will not check it here..

As everyone else seems to run the bot with no problems i must be a block.

Either Funcom or the company hosting my server.

Title: Re: BeBot v0.6.6 released - The not so scary halloween edition
Post by: Khalem on October 31, 2009, 12:43:36 am
If you server host allows remote database connections, there is nothing to stop you from running the bot from your local machine connected to the server host database just for testing purposes.

I would also check if the DNS entries are being resolved properly on your server.
For example you can use http://www.kloth.net/services/dig.php and enter the nameserver your server host provides, provided it allows remote queries from outside the facility or most likely the dig tool itself will be installed on the server.
Title: Re: BeBot v0.6.6 released - The not so scary halloween edition
Post by: WeZoN on November 03, 2009, 09:17:45 pm
it's tested and the aoc connection on my server is indeed blocked...

Most likely by the company that hosts it. As the bot has spammed the login to aoc after the login changes made by funcom.