Booya
collapse collapse

Menu

* User Info

 
 
Welcome, Guest. Please login or register.
Did you miss your activation email?

* Search


* Board Stats

  • stats Total Members: 1061
  • stats Total Posts: 18264
  • stats Total Topics: 2479
  • stats Total Categories: 7
  • stats Total Boards: 31
  • stats Most Online: 178

Author Topic: MySQL n00b help.  (Read 51828 times)

0 Members and 1 Guest are viewing this topic.

Offline Shelly

  • BeBot Apprentice
  • ***
  • Posts: 192
Re: MySQL n00b help.
« Reply #30 on: October 12, 2012, 02:48:30 am »
Hi there
Another gimp hehe.
Bot runs fine, however, what settngs do i need to change, and to what, running org bot and a raid bot, to fix :
1: Raid bot dont spam org bot
log in as your <orgbot> and /ignore <raidbot>
2: Raid bot holds all org members as *members* so they can logg on to raidbot.
make sure your raidbot is a member of your org. then look at the /tell raidbot !security
3: Alts have same rank on both bots.
See item 2 :)
4: enable wave counter in city raid
/tell orgbot !AlienAttack
and look at the settings.
I have more questions, but wana go slow :)

Hope this helps :)

Shelly

Offline Qcbcal50

  • BeBot Rookie
  • *
  • Posts: 4
Re: MySQL n00b help.
« Reply #31 on: October 12, 2012, 07:13:48 pm »
didnt work to ignor raidbot, might be some issues on that bot setup, working on it.
testing the rest atm :)
Thx for help anyway :)
I will ask more hehe

Offline Qcbcal50

  • BeBot Rookie
  • *
  • Posts: 4
Re: MySQL n00b help.
« Reply #32 on: October 12, 2012, 08:19:13 pm »
/tell orgbot !AlienAttack didnt work either, have no clue why.

Offline Shelly

  • BeBot Apprentice
  • ***
  • Posts: 192
Re: MySQL n00b help.
« Reply #33 on: October 14, 2012, 02:38:34 am »
/tell orgbot !AlienAttack didnt work either, have no clue why.
You probably do not have the module I wrote installed. :)

Have a look at: http://bebot.shadow-realm.org/ao-0-6-x-customunofficial-modules/city-alien-attack-wave-mod/msg16504/#msg16504

Offline Vetiver

  • BeBot Rookie
  • *
  • Posts: 3
Re: MySQL n00b help.
« Reply #34 on: May 26, 2013, 12:39:32 am »
I am trying to set up MySQL, and I am getting this message when I try to configure it.

mysql-server-5.6-win32:56 - Adding firewall rule for MySQL56 on port 3306.
mysql-server-5.6-win32:62 - Successfully added firewall rule.
mysql-server-5.6-win32:68 - Attempting to update security settings.
mysql-server-5.6-win32:100 - Unable to update security settings. Access denied for user 'root'@'localhost' (using password: NO)
mysql-server-5.6-win32:75 - Attempting to verify command-line client shortcut.
mysql-server-5.6-win32:100 - Failed to verify command-line client shortcut.
mysql-server-5.6-win32:81 - Attempting to Add New MySQL Users
mysql-server-5.6-win32:100 - Unable to add New Users. Access denied for user 'root'@'localhost' (using password: YES)
mysql-server-5.6-win32:100 - Product configuration controller finished configuration.

Then it finishes, but tells me the configuration failed.  I tried turning the firewall off, no luck...  I am not sure where the security settings it is trying to update are.  Any suggestions?

Offline dragonjr

  • BeBot Apprentice
  • ***
  • Posts: 131
Re: MySQL n00b help.
« Reply #35 on: May 26, 2013, 02:25:20 am »
look at reply #11 it sounds like the issue you are having just and idea though

Offline Shelly

  • BeBot Apprentice
  • ***
  • Posts: 192
Re: MySQL n00b help.
« Reply #36 on: May 26, 2013, 11:52:57 pm »
I am trying to set up MySQL, and I am getting this message when I try to configure it.

[snip]

mysql-server-5.6-win32:100 - Unable to update security settings. Access denied for user 'root'@'localhost' (using password: NO)

[snip]

mysql-server-5.6-win32:100 - Unable to add New Users. Access denied for user 'root'@'localhost' (using password: YES)
mysql-server-5.6-win32:100 - Product configuration controller finished configuration.

Then it finishes, but tells me the configuration failed.  I tried turning the firewall off, no luck...  I am not sure where the security settings it is trying to update are.  Any suggestions?

You did not setup MySQL correctly. The application cannot log into the server (not a firewall issue there). The password you set for user root is not matching -or- you forgot to allow from localhost in the MySQL user permissions.

Shelly

Offline Vetiver

  • BeBot Rookie
  • *
  • Posts: 3
Re: MySQL n00b help.
« Reply #37 on: May 28, 2013, 05:56:59 pm »
Thanks, Shelly!  Any idea where I need to look to add that root user?  I *thought* I  had set up root, but not sure now.  I did something with a root user, and made sure to write down the password, but...  I gather that is not the same as root @ localhost?  Where do I allow localhost?

Offline Shelly

  • BeBot Apprentice
  • ***
  • Posts: 192
Re: MySQL n00b help.
« Reply #38 on: May 29, 2013, 02:44:38 am »
Not wanting to overwhelm you with *all* the details ^_^ here are a couple good to know links to get you going.

This link --> MySQL Documentation & Help <-- has a wealth of information about what to do to setup MySQL.

I suggest --> MyPhpAdmin <-- as a tool to help you administer your MySQL installation. :)

Offline dragonjr

  • BeBot Apprentice
  • ***
  • Posts: 131
Re: MySQL n00b help.
« Reply #39 on: April 10, 2014, 04:02:17 am »
ok i had to re-install the bot and i havent had to play with the files in a long time and i thought i did everything right but im getting a error


Code: [Select]
Fatal error: Call-time pass-by-reference has been removed in C:\bebot\Main.php o
n line 298

Fatal error: Call-time pass-by-reference has been removed in C:\bebot\Main.php o
n line 298

Fatal error: Call-time pass-by-reference has been removed in C:\bebot\Main.php o
n line 298

Fatal error: Call-time pass-by-reference has been removed in C:\bebot\Main.php o
n line 298

Fatal error: Call-time pass-by-reference has been removed in C:\bebot\Main.php o
n line 298

Fatal error: Call-time pass-by-reference has been removed in C:\bebot\Main.php o
n line 298

Fatal error: Call-time pass-by-reference has been removed in C:\bebot\Main.php o
n line 298
 
what am i doing wrong ?
any help would be grate thanks

Offline Tyrence

  • BeBot User
  • **
  • Posts: 41
Re: MySQL n00b help.
« Reply #40 on: April 18, 2014, 09:32:40 am »
I'm guessing you moved the bot to a new server or similar?  The problem is that the version of Bebot you are running (or one of the modules) is designed for an older version of PHP than you are running.

First thing would be to try with the latest version of Bebot.  If that doesn't work then you need to install an older version of PHP (and make sure Bebot uses that older version).  I am not familiar enough with Bebot to say which version you should use, but probably PHP 5.3 or 5.2.
« Last Edit: April 18, 2014, 09:45:05 am by Tyrence »

Offline twig

  • BeBot Rookie
  • *
  • Posts: 2
Re: MySQL n00b help.
« Reply #41 on: February 28, 2015, 12:22:05 am »
Ok i'm getting this:

Fatal error:  Call-time pass-by-reference has been removed in C:\Bebot\Main.php on line 298

any suggestions?

I followed these instructions http://bebot.shadow-realm.org/wiki/installation.

Offline twig

  • BeBot Rookie
  • *
  • Posts: 2
Re: MySQL n00b help.
« Reply #42 on: February 28, 2015, 04:55:09 am »
ok got the Main.php fixed now a new issue.

Bot configuration is outdated or corrupted.
Please check it's contents against the template.

Any suggestions?

 

* Recent Posts

Bot hosting (UtAvDrift Hosting) by Tessman
[August 24, 2017, 10:19:33 am]


CIDB by bitnykk
[July 21, 2017, 10:19:38 am]


Line 99 StartBot.php by Kepha
[October 17, 2016, 10:37:57 am]


New Central itemDB (!item[s|reg]) by aoc_botter
[September 17, 2016, 07:06:44 pm]


Unknown dimension error. by aoc_botter
[September 17, 2016, 06:53:20 pm]

* Who's Online

  • Dot Guests: 23
  • Dot Hidden: 0
  • Dot Users: 0

There aren't any users online.

* Forum Staff

Khalem admin Khalem
Administrator
WeZoN gmod WeZoN
Global Moderator