Booya
collapse collapse

* User Info

 
 
Welcome, Guest. Please login or register.
Did you miss your activation email?

* Search


* Board Stats

  • stats Total Members: 1074
  • stats Total Posts: 18300
  • stats Total Topics: 2487
  • stats Total Categories: 7
  • stats Total Boards: 31
  • stats Most Online: 500

Author Topic: TWC  (Read 36085 times)

0 Members and 1 Guest are viewing this topic.

Offline Temar

  • Contributor
  • *******
  • Posts: 1140
  • Karma: +0/-0
    • AoFiles
Re: AOWC
« Reply #30 on: July 30, 2008, 03:27:34 pm »
Thanks!

I got it working i think...

What commands / what do i need to do to get it working?
So far I register and thats it...

when I type in my username and password, I get Higher Access is Required to View this.

Ask Org for Access:

My question is what do i put in the box and what is it supposed to do?

Thanks.

you can iver turn it off in the install

or

when u ask for access it will send a message to your org chat, and perminent or temporary access can be given

i plan on adding other ways after i got admin section done

Offline Temar

  • Contributor
  • *******
  • Posts: 1140
  • Karma: +0/-0
    • AoFiles
Re: AOWC
« Reply #31 on: July 30, 2008, 03:38:49 pm »
Forum MySQL Server: I dont have a forum  this is also used for the tables made and used by aowc webside
Address Server is Located at, Usually localhost

Forum MySQL Username:
Username to Connect to MySQL Server

Forum MySQL Password:
Password to Connect to MySQL Server

Bot MySQL Server: *this is bebots db connection right* yes
Address Server is Located at, Usually localhost

Bot MySQL Username:
Username to Connect to MySQL Server

Bot MySQL Password:
Password to Connect to MySQL Server

Forum Database: *no forum* this is also used for the tables made and used by aowc webside
This is Were your Forum Tables are located

Forum Prefix:
This is the Prefix Used on the forum Tables

OrgBot Database: *hold on what's this? no you havent you gave the server connection details not the database
What database does your OrgBot Use

OrgBot Name: *see above this is the character name of your bot (this is currently case sensative)
What nickname does your OrgBot Use

Online OrgBot Names: *Now I am completely lost*you can just put your botname, the example is how to do it for milti orgs
What nicknames should be check for the Online list, seperate with ; and , E.G. bot1,org1;bot2,org2

AOWC Table Database: *should I create a db for aowc?*thats up 2 you, but i plan on merging the option for forum_db and aowc_db so keep that in mind
What Database Should the AOWC tables be made on

AOWC Table Prefix:
What prefix Should the AOWC table names use ( Not Required )

Forum Root Path: *no forum again* not required then
This is the Internal Path for Forum

AOWC Root Path: It seems to have filled this out
This is the Internal Path for AOWC

AOWC URL: IT filled this one out as well
This is the URL for AOWC

Forum Type:  SMF  PHPBB  AOWC - yes AOWC What type of forum is used for users

Allow New Members Access:  YesAre New user Allowed access, if no then they need to be in dif group than starting on Huh??user have same level to start with regardless of this setting, but this setting allows the default level to use AOWC
Notes:
* Will update AOWC User Table if Already Exists
* Install Bot Module on Atleast 1 Bot and Restart to have that Setting confirmed (not required) Huh restart what?youor org bot after putting the module in it
* The user_prefs and settings table is made on same Server as forum - I think I understand this
* AOWC user mode uses Forum Server Settings - if you use mode AOWC for users, it uses connection details for forum for the tables
 
« Last Edit: July 30, 2008, 03:43:12 pm by Temar »

Offline Temar

  • Contributor
  • *******
  • Posts: 1140
  • Karma: +0/-0
    • AoFiles
Re: AOWC
« Reply #32 on: July 30, 2008, 03:41:21 pm »
that means you dont have the IRC module loaded yet
this can be cause by putting it in /core/
and the moule doesnt require support module anymore its been updated
IRC.php is in /modules/ so is loaded after /core/ module

Offline jarvil

  • BeBot Rookie
  • *
  • Posts: 13
  • Karma: +0/-0
Re: AOWC
« Reply #33 on: July 30, 2008, 04:28:24 pm »
After four hours.... its working!!!!  ;D  ;D  ;D

To install standalone you need to do the following...

There is not a guide on what needs to go where first. The bot must be already working before adding AOWC. In this example I am using bebot-hyperborean 0.5.2 r17 with the suggested php package. I am running AOWC Lite 2.0 on Uniform Server (php/mysql/apache) under Windows Vista.
 
a) create the aowc user with mysql database of same name and grant all priviledges
b) download AOWC lite 2.0, run the aowc_install.php.
c) put the bot\AOWC.php in bebot\custom\modules direcotory
d) restart the bot.
e) Bring up the main page http://localhost/aowc/aowc.php and register a new user
f) Login and see how you go.

Tips
Their is no default page for http://localhost/aowc so you need to specify http://localhost/aowc/aowc.php for the moment.

aowc_install.php is sensitive and needs to be done in a certain way to complete without errors. Not sure why forum db name is required however the installation SQL commands show errors without it. Here is a guide to the install page.

Forum MySQL Server: localhost
Forum MySQL Username: aowc
Forum MySQL Password: *********
Bot MySQL Server: localhost
Bot MySQL Username: bebot
Bot MySQL Password: ***********
Forum Database: aowc
OrgBot Database: bebot
OrgBot Name: bbchat (case sensitive)
Online OrgBot Names: bbchat
AOWC Table Database: aowc
AOWC Root Path: Leave as default unless its wrong
AOWC URL: Leave as default unless its wrong
Forum Type:  AOWC
Allow New Members Access:  Yes

I hope that helps :-)

Regards

Jarvil
« Last Edit: July 30, 2008, 05:37:52 pm by jarvil »

Offline jarvil

  • BeBot Rookie
  • *
  • Posts: 13
  • Karma: +0/-0
Re: AOWC
« Reply #34 on: July 30, 2008, 05:47:13 pm »
Just noticed if you add an entry in our hosts file for another site name such as chat.myguild.org pointing to 127.0.0.1. Then if you try to access AOWC using that site name you can register but the chat never comes up. http://localhost works.

Regards

Jarvil

Offline Temar

  • Contributor
  • *******
  • Posts: 1140
  • Karma: +0/-0
    • AoFiles
Re: AOWC
« Reply #35 on: July 30, 2008, 06:49:49 pm »
the URL is used for auto-refresh etc action that dont required reloading of the page, which is done by calling another page at the URL you say, so the url has to be readable by the user and the location of the files

localhost would onl work for the user that on the same machine

Offline jarvil

  • BeBot Rookie
  • *
  • Posts: 13
  • Karma: +0/-0
Re: AOWC
« Reply #36 on: August 01, 2008, 09:26:04 am »
Just noticed if you add an entry in our hosts file for another site name such as chat.myguild.org pointing to 127.0.0.1. Then if you try to access AOWC using that site name you can register but the chat never comes up. http://localhost works.

This was because I needed to update the URL in settings.php. My fault for not doing this. Its all working now. Learning fast...

Now lets see if I can get joomla CMS integration working for username/password. Need it for my site. How do I go about working on your code? just go ahead and use SVN or have to ask your permission? Would like to create a Wiki entry for installing this as well.

After that want to enable tells and online user list on RHS.

Regards

Jarvil
« Last Edit: August 01, 2008, 09:36:17 am by jarvil »

Offline Temar

  • Contributor
  • *******
  • Posts: 1140
  • Karma: +0/-0
    • AoFiles
Re: AOWC
« Reply #37 on: August 01, 2008, 12:33:34 pm »
i have unlocked the SVN server
u can commit your changes and ill have a look

Offline jarvil

  • BeBot Rookie
  • *
  • Posts: 13
  • Karma: +0/-0
Re: AOWC
« Reply #38 on: August 01, 2008, 09:36:12 pm »
Some wiki-ness

http://bebot.shadow-realm.org/wiki/aowc

Todo
Bebot chat not come up white.
Enable Send/Recieve tells from AOWC
Online user list
Bring up item information in new window from itemref:// links. (Bot to query server)
Webauth integration with Joomla

Bugfix Todo
!quotes not appearing in webchat
Ignore empty line from AOWC
« Last Edit: August 04, 2008, 07:00:02 am by jarvil »

Offline Temar

  • Contributor
  • *******
  • Posts: 1140
  • Karma: +0/-0
    • AoFiles
Re: AOWC
« Reply #39 on: August 07, 2008, 04:30:56 am »
Some wiki-ness

http://bebot.shadow-realm.org/wiki/aowc

Todo
Bebot chat not come up white.  not sure what you mean
Enable Send/Recieve tells from AOWC
Online user list
Bring up item information in new window from itemref:// links. (Bot to query server) it currently Links Items to Auno altho there maybe a few bugs with the detection
Webauth integration with Joomla

Bugfix Todo
!quotes not appearing in webchat whats not apearing?
Ignore empty line from AOWC  yer sending blank msg should be stoped will do soon Done
« Last Edit: August 07, 2008, 08:57:51 am by Temar »

Offline clashbot

  • BeBot Expert
  • ****
  • Posts: 295
  • Karma: +0/-0
    • Ascension's Home
Re: AOWC
« Reply #40 on: August 09, 2008, 03:51:29 pm »
I am guessing this is another one of those modules that I would have to have the forum db and the bot db on the same machine. I am running an smf/tp org forum on a hosting site, while running the bots from a local computer here. I've uploaded the files, I've set the permissions to allow the execution of scripts, and when I type in the address for the aowc_install I get a blank page. I've set permissions for all the php files for read/write/execute.

Offline Temar

  • Contributor
  • *******
  • Posts: 1140
  • Karma: +0/-0
    • AoFiles
Re: AOWC
« Reply #41 on: August 09, 2008, 04:23:19 pm »
in version 2.0 (available from SVN) u can use dif host for forum/aowc tables and Bot tables
No this doesnt require a Forum, it has a built in login system if you dont use a forum
going to aowc_install.php should work fine as far as i know

Offline clashbot

  • BeBot Expert
  • ****
  • Posts: 295
  • Karma: +0/-0
    • Ascension's Home
Re: AOWC
« Reply #42 on: August 09, 2008, 04:28:05 pm »
yeah I downloaded the 2.0 the install php just displays a blank page. I just noticed that there are two <?php ... ?> sections separated by the html css, could this be causing the problem?

Offline clashbot

  • BeBot Expert
  • ****
  • Posts: 295
  • Karma: +0/-0
    • Ascension's Home
Re: AOWC
« Reply #43 on: August 09, 2008, 04:32:16 pm »
ok removing the first php set and the stylesheet I get this errror:

Fatal error: Class install_aowc: Cannot inherit from undefined class sql in /home/content/g/w/y/gwyndion6977/html/personal/ascension/ascforum/aowc/aowc_install.php on line 3

Offline Temar

  • Contributor
  • *******
  • Posts: 1140
  • Karma: +0/-0
    • AoFiles
Re: AOWC
« Reply #44 on: August 09, 2008, 04:37:09 pm »
that error is prob cuz u just removed require("sql.php")

 

* Recent Posts

0.7.0 updates by bitnykk
[May 17, 2020, 04:22:04 pm]


Stats module by bitnykk
[April 16, 2020, 04:45:43 pm]


OnlineOrg by Hell
[February 28, 2020, 11:21:55 pm]


AO Bots - discord server by Kjellis1234
[January 23, 2020, 04:17:04 pm]


Offline AA training timer module by Kjellis1234
[August 29, 2019, 11:12:14 pm]

* Who's Online

  • Dot Guests: 193
  • Dot Hidden: 0
  • Dot Users: 0

There aren't any users online.

* Forum Staff

bitnykk admin bitnykk
Administrator
Khalem admin Khalem
Administrator
WeZoN gmod WeZoN
Global Moderator
SimplePortal 2.3.7 © 2008-2020, SimplePortal