Booya
collapse collapse

* User Info

 
 
Welcome, Guest. Please login or register.
Did you miss your activation email?

* Search


* Board Stats

  • stats Total Members: 1074
  • stats Total Posts: 18300
  • stats Total Topics: 2487
  • stats Total Categories: 7
  • stats Total Boards: 31
  • stats Most Online: 500

Author Topic: TeamSpeak  (Read 11606 times)

0 Members and 1 Guest are viewing this topic.

Offline Temar

  • Contributor
  • *******
  • Posts: 1140
  • Karma: +0/-0
    • AoFiles
TeamSpeak
« on: February 18, 2009, 08:38:27 pm »
This module Allows you to View who is on the TeamSpeak Server
this module wasnt originally Created by me However i have Made Lots of improvements including to work with 0.6

1 thing i added was Also for the Bot to monitor TeamSpeak for Changes in User List and announce Joins and Leaves

Download
  http://www.aofiles.com/index.php?action=user_file&owner=temar&file=TeamSpeak
« Last Edit: February 18, 2009, 08:41:38 pm by Temar »

Offline jimango

  • BeBot User
  • **
  • Posts: 36
  • Karma: +0/-0
Re: TeamSpeak
« Reply #1 on: February 20, 2009, 06:47:39 am »
very nice module.. thank you!

but where do i put in the servername and password so it can be shown for my members?

I dont see what channel im in, is there something more i need to do then?


Offline Temar

  • Contributor
  • *******
  • Posts: 1140
  • Karma: +0/-0
    • AoFiles
Re: TeamSpeak
« Reply #2 on: February 20, 2009, 08:16:18 am »
i dont think it currently shows channels
and as for the server details both for use and show its all under the settings

Offline jimango

  • BeBot User
  • **
  • Posts: 36
  • Karma: +0/-0
Re: TeamSpeak
« Reply #3 on: February 21, 2009, 10:13:17 am »
Is there any one that might wanna add channels to it?
I like the design of it very well..
But would be nice to see who changed to PvP channel og away channel.. for example.


Offline MysterF

  • BeBot User
  • **
  • Posts: 25
  • Karma: +0/-0
Re: TeamSpeak
« Reply #4 on: February 27, 2009, 04:53:45 pm »
I need some help in setting up the teamspeak module.

Tech details:
Im' running bebot v.0.6.2
mySQL v.5.1.31(win32)
PHP v.5.2.8 (win32)
game:Age of Conan

I've downloaded the "Teamspeak.phps" file and renamed it to "Teamspeak.php"
then i copied the file in  "custom\modules\" directory, I've restarted the bot and the file seems to get loaded.

Issue:
Whiles I'm in game and i try the "!ts" command nothing shows so clearly I'm doing something wrong there.
I also edited the following part of the file
Code: [Select]
$this -> bot -> core("settings") -> create("TeamSpeak", "cron", FALSE, "Shold bot Keep check TS for User that have joined or left Teamspeak?");
$this -> bot -> core("settings") -> create("TeamSpeak", "ip", "localhost", "What is the Server IP? (used by module)");
$this -> bot -> core("settings") -> create("TeamSpeak", "queryport", 51234, "What is the Server Query Port? (used by module)");
$this -> bot -> core("settings") -> create("TeamSpeak", "port", 8767, "What is the Server Port? (used by users)");
$this -> bot -> core("settings") -> create("TeamSpeak", "name", "", "What is the Server Name?");
$this -> bot -> core("settings") -> create("TeamSpeak", "host", "", "What is the Server Address? (used by users)");
$this -> bot -> core("settings") -> create("TeamSpeak", "password", "", "What is the Server password? (used by users)");

But again with or without the file settings edited  the "!ts" command still not works.
Any input on this matter is appreciated, I'm clueless at the moment.
I didn't had any problems installing other modules but I'm sure I'm missing  something here.
« Last Edit: February 27, 2009, 04:56:11 pm by MysterF »

Offline Temar

  • Contributor
  • *******
  • Posts: 1140
  • Karma: +0/-0
    • AoFiles
Re: TeamSpeak
« Reply #5 on: February 27, 2009, 07:32:56 pm »
u setup teamspeak useing settings
this means doing !set teamspeak
u will see a list of stuff u can change
for say port u can do
!set teamspeak port <port>

Offline MysterF

  • BeBot User
  • **
  • Posts: 25
  • Karma: +0/-0
Re: TeamSpeak
« Reply #6 on: March 13, 2009, 08:41:21 am »
Ofcourse i had to fix it myself, by doing a very simple thing:

Your scrip starts like this:

Code: [Select]
<?
$ts = new Teamspeak(&$bot);


i just added this

<?php

$ts = new Teamspeak(&$bot);

..i was so stupid how  i missed that little thing  for so long.=)
....my problem wasn't the  teamspeak configuration.. the module simply didn't load.
« Last Edit: March 13, 2009, 03:00:34 pm by MysterF »

Offline Temar

  • Contributor
  • *******
  • Posts: 1140
  • Karma: +0/-0
    • AoFiles
Re: TeamSpeak
« Reply #7 on: March 13, 2009, 08:58:51 pm »
oh yer some server dont like it when u only do <?

Offline MysterF

  • BeBot User
  • **
  • Posts: 25
  • Karma: +0/-0
Re: TeamSpeak
« Reply #8 on: March 14, 2009, 02:13:38 pm »
oh yer some server dont like it when u only do <?

not only that they don't like it they simply don't load the module.-)
was weird to see all my problems with this module were related to that "php" thingy -)

on a side note:the ts  module is perfect, i especially like the "xx logged on to Teamspeak" notification.
Thx again.

Offline Rekkx

  • BeBot Rookie
  • *
  • Posts: 8
  • Karma: +0/-0
Re: TeamSpeak
« Reply #9 on: March 25, 2009, 12:33:10 pm »
I'm having trouble getting this module to work. The scenario is this:

On botstart there is an error which I believe is returning a null in the startup() function.

The module continues to load without any problem and when using the !ts command in-game, the info window shows all the details correctly but the module fails to register and user interaction from the TS Server. It continually says there are no users online with no notifications etc.

Is there anything specific you need to do with the TS server or what in the module could be casuing this behaviour?

Offline Temar

  • Contributor
  • *******
  • Posts: 1140
  • Karma: +0/-0
    • AoFiles
Re: TeamSpeak
« Reply #10 on: March 26, 2009, 05:41:19 am »
that sounds like it cant connect to the teamspeak server
u got the details right? remember is uses query port not the normal port

Offline Rekkx

  • BeBot Rookie
  • *
  • Posts: 8
  • Karma: +0/-0
Re: TeamSpeak
« Reply #11 on: March 26, 2009, 12:37:31 pm »
I'm pretty sure it's right as before I changed the query port from the default, I got the "TS is not connected" message when using !ts, now I'm getting the info, just no interaction.

I will try to get more information if I can and come back a bit later.

Thanks for taking the time to reply Temar.

Offline Tealc1

  • BeBot Rookie
  • *
  • Posts: 3
  • Karma: +0/-0
Re: TeamSpeak
« Reply #12 on: April 04, 2009, 01:32:23 pm »
This link is dead.

Where can i download the file ?


Tealc1 from DNW

Offline Margon

  • BeBot Apprentice
  • ***
  • Posts: 80
  • Karma: +0/-0
Re: TeamSpeak
« Reply #13 on: November 08, 2009, 11:04:57 am »
is there a way to show the channels and the players inside? not only the list of connected players

Offline dioniz84

  • BeBot Rookie
  • *
  • Posts: 16
  • Karma: +0/-0
Re: TeamSpeak
« Reply #14 on: December 09, 2009, 12:08:19 pm »
Is there a similar module for Mumble ?? Or is it possible to modify this one to work with mumble??

 

* Recent Posts

0.7.0 updates by bitnykk
[May 17, 2020, 04:22:04 pm]


Stats module by bitnykk
[April 16, 2020, 04:45:43 pm]


OnlineOrg by Hell
[February 28, 2020, 11:21:55 pm]


AO Bots - discord server by Kjellis1234
[January 23, 2020, 04:17:04 pm]


Offline AA training timer module by Kjellis1234
[August 29, 2019, 11:12:14 pm]

* Who's Online

  • Dot Guests: 191
  • Dot Hidden: 0
  • Dot Users: 0

There aren't any users online.

* Forum Staff

bitnykk admin bitnykk
Administrator
Khalem admin Khalem
Administrator
WeZoN gmod WeZoN
Global Moderator
SimplePortal 2.3.7 © 2008-2020, SimplePortal