Booya
collapse collapse

Menu

* User Info

 
 
Welcome, Guest. Please login or register.
Did you miss your activation email?

* Search


* Board Stats

  • stats Total Members: 1062
  • stats Total Posts: 18264
  • stats Total Topics: 2480
  • stats Total Categories: 7
  • stats Total Boards: 31
  • stats Most Online: 178

Author Topic: Roster update failed  (Read 4257 times)

0 Members and 1 Guest are viewing this topic.

Offline Foodor

  • BeBot Rookie
  • *
  • Posts: 6
Roster update failed
« on: May 30, 2013, 09:14:28 pm »
Hey fellas,

I'm sure this has been discussed million times but didn't find any direct correction for this while searching. So I still have this old problem:

Buchio [CORE]   [INC_GANNOUNCE] Detected org name as: OnTT
Buchio [SETTINGS]       [LOAD]  Loaded settings from database.
Buchio [ROSTER] [UPDATE]        Starting roster update for guild id: 9605 on RK1
Buchio [ROSTER] [UPDATE]        XML for the  guild  obtained
Buchio [ROSTER] [UPDATE]        Roster update failed. Funcom XML returned 0 members.
Buchio [ROSTER] [UPDATE]        Starting roster update for guild id: 9605 on RK1
Buchio [ROSTER] [UPDATE]        XML for the  guild  obtained
Buchio [ROSTER] [UPDATE]        Roster update failed. Funcom XML returned 0 members.


I did fix file 10_Roster.php like this as guided in one other thread:

#->get_site("http://people.anarchy-online.com/org/stats/d/$dim/name/$id/basicstats.xml");
                ->get_site("http://people.anarchy-online.com/org/stats/d/1/name/$id/basicstats.xml");

But still it keeps saying roster update failed 0 members

Foo

Offline Shelly

  • BeBot Apprentice
  • ***
  • Posts: 192
Re: Roster update failed
« Reply #1 on: June 01, 2013, 04:21:37 am »
Try promoting your bot character in the org to officer level.

Offline Foodor

  • BeBot Rookie
  • *
  • Posts: 6
Re: Roster update failed
« Reply #2 on: June 10, 2013, 10:14:12 pm »
Now I get this kind of error

Buchio [LOGIN]  [STATUS]        Connecting to ao server chat.d1.funcom.com:7105
Buchio [LOGIN]  [STATUS]        Authenticating xxxxx
Buchio [LOGIN]  [STATUS]        Logging in Buchio
Buchio [LOGIN]  [RESULT]        OK
Buchio [SETTINGS]       [LOAD]  Loaded settings from database.
Buchio [CORE]   [INC_GANNOUNCE] Detected org name as: OnTT
Read error: EOF
Buchio [CONN]   [ERROR] Bot has disconnected. Reconnecting in 60 seconds.

Offline Shelly

  • BeBot Apprentice
  • ***
  • Posts: 192
Re: Roster update failed
« Reply #3 on: June 10, 2013, 11:08:59 pm »
What version of the bot are you running?

You may want to look at this thread and see if it helps you --> http://bebot.shadow-realm.org/ao-0-6-support/server-merge!/msg18432/#msg18432

I would also make sure that account is good by logging in via a client to make sure the bot character is activated.

Just my thoughts...

Shelly
« Last Edit: June 10, 2013, 11:11:54 pm by Shelly »

Offline Khalem

  • BeBot Founder
  • Administrator
  • ********
  • Posts: 1169
    • http://www.ancarim.com
Re: Roster update failed
« Reply #4 on: August 06, 2013, 07:57:34 pm »
Apologies for late reply.

Please try the latest snapshot:
https://github.com/J-Soft/BeBot-legacy/archive/master.zip
BeBot Founder and Fixer Kingpin

 

* Recent Posts

Some slight issues! by bitnykk
[October 04, 2017, 11:53:10 am]


Bot hosting (UtAvDrift Hosting) by Tessman
[August 24, 2017, 10:19:33 am]


CIDB by bitnykk
[July 21, 2017, 10:19:38 am]


Line 99 StartBot.php by Kepha
[October 17, 2016, 10:37:57 am]


New Central itemDB (!item[s|reg]) by aoc_botter
[September 17, 2016, 07:06:44 pm]

* Who's Online

  • Dot Guests: 27
  • Dot Hidden: 0
  • Dot Users: 0

There aren't any users online.

* Forum Staff

Khalem admin Khalem
Administrator
WeZoN gmod WeZoN
Global Moderator