BeBot - An Anarchy Online and Age Of Conan chat automaton

Anarchy Online => AO 0.6.x Custom/Unofficial modules => Topic started by: Nogoal on August 24, 2011, 06:20:36 pm

Title: [AO] Items module v1.2.1
Post by: Nogoal on August 24, 2011, 06:20:36 pm
Quickly updated the official module to support the slot and type from CIDB version 1.2.1

Items.phps (http://www.dokushuu.com/pics/Items.phps)

1. Download the file and save it in your "bot/custom/modules" folder.
2. Rename it to Items.php
3. Go to "bot/modules/ao"
4. Rename Items.php to _Items.php
3. restart your bot

-------------------
v1.2.1

/tell <botname> settings items
- Icons: on|off (doesn't seem to work => should I remove it?; default: on)
- Max: integer (max number of results; default: 50)
- Server: url (if we ever have to change it again; default: http://cidb.botsharp.net/)

/tell <botname> color module items
- header (default: fuchsia)
- highlight (default: bluegray)
- normal (default: white)
Title: Re: [AO] Items module v1.2
Post by: Vhab on August 25, 2011, 10:06:42 am
I approve of this plugin.

You might want to remove the "Latest version can always be found at" part :P
I added that to the original version and you have my permission to remove it.
Title: Re: [AO] Items module v1.2
Post by: Nogoal on August 26, 2011, 03:57:05 pm
Thank you for you permission!

I updated it and more! You can now change settings in game without having to edit the file.
Title: Re: [AO] Items module v1.2.1
Post by: laryllan on January 14, 2012, 03:52:23 pm
The bot says: "Unable to query database"...

Did the URL change again?
Title: Re: [AO] Items module v1.2.1
Post by: bitnykk on February 27, 2019, 11:35:12 am
My current project is to find a way to make the !items module work again.

Please first check what URL your module code features to connect. Most of the old CIDB (eg xyphos or vhab) are now offline, unfortunately. The only i know still working & updated by now is http://cidb.botsharp.net/ maintained by Demoder (the coder also behind aoitems.com).
Title: Re: [AO] Items module v1.2.1
Post by: Kjellis1234 on March 01, 2019, 04:59:50 pm
I was thinking more of the items.php module for Age of Conan  :)

Or does this work for both games?

And do you have the items.php file? The link seems to not work anymore.